Ankündigung

Einklappen
Keine Ankündigung bisher.

Projecta Anpassung im vertikalem Menü

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Projecta Anpassung im vertikalem Menü

    Hallo, ich habe mir Projecta installiert. Ich scheitere jedoch daran, mir das vertikale Menü anzupassen. Ich hätte unter diesem Menü gerne eine Suchfunktion, einen kurzen Text und wiederrum darunter zwei Buttons (Call to Action) - entweder beide untereinander oder beide nebeneinander in einer Zeile, das dürfte erstmal jedoch nebensächlich sein.
    Nun habe ich folgende Probleme:
    • Die Suchfunktion bekomme ich gar nicht eingebledet
    • Ich bekomme Text und Buttons nur in den Bereich zw. Logo und Menü, statt unterhalb des Menüs UND: nur auf der Home Seite, nicht auf den anderen
    • Der Abstand der von mir eingefügten Elemente ist zu viel (250px). Füge ich eine custom.css in Content-Page - Full Width oder Content-Page - Sidebar left ein, werden die dortigen Angaben ignoriert.
    • Ich finde keinen Weg die Call to Action Buttons aus der Vorlage dort einzufügen - ich kann nur unattraktive Buttons mittels HTML Button Tag einblenden.
    Ich wäre um einen Tipp dankbar, wie das geht. Vermutlich bin ich das ganze falsch angegangen.

  • #2
    Hallo,
    die Suchfuntion ist mit Sicherheit nicht mehr sichtbar, weil die eingefügten Elemente sowohl Suche als auch Sprachenwechsler aus dem Bereich drücken. Das Layout baut an dieser Stelle auf absolute Positionierungen der Elemente Suche und Sprachwechsler am unteren Bereich auf.
    - Der Abstand von 250px entspricht dem Standard line-height in diesem Bereich bzw. werden dort Artikel eingebunden (mod_article) bekommen diese vom Theme-Standard ein padding-top,bottom von jeweils 100px. (In den Artikel-Einstellungen kann das Padding entfernt werden)
    - Weitere Elemente aus Artikeln können nach dem Hinzufügen der Artikel-Ausgabe im Layoutbereich Kopfzeile in den Seitenlayouts ergänze werden. Das Projecta Layout wandelt quasi den normalen Kopfbereich in eine fliegende Links Spalte. (siehe Screenshot _69)
    - Für die Anpassungen der ergänzen Elemente (ich würde hier ein absolutes Styling empfehlen, damit es mit den bestehenden Elementen nicht kollidiert, oder die absoluten Elemente wieder relative setzen), kann die mitgelieferte customize.css Datei genutzt werden (files/cto_layout/css/customize.css). Diese wird immer eingebunden.

    Viele Grüße, Tim
    Angehängte Dateien
    Zuletzt geändert von Tim; 28.09.2021, 08:36.
    http://www.premium-contao-themes.com

    Kommentar


    • #3
      Hallo Tim, vielen Dank. Abgesehen von deinem Hinweis mit der customize.css Datei komme ich nicht weiter.
      Ich hatte mir einen Text als "Eigenen HTML Code" ganz am Anfang in die linke Spalte integriert. Das hatte geklappt (das war bevor ich hier gepostet habe). Aber ich schaffe es nun nicht mal testweise das Logo oder die Social Icons auszublenden. Daher bekomme ich auch nicht die Suche wieder eingeblendet da ich wohl an einem falschen Punkt suche oder weil was anderes nicht stimmt. Um testweise die Social Icons auszublenden gehe ich doch zu Themes -> Eclipse -> Seitenlayouts -> Content-Page - Sidebar left und deaktiviere 1 Themesetting: Socials (Eigener HTML Code) / Kopfzeile (für die Desktop-Ansicht), oder?

      Kommentar


      • #4
        Logo und Social Icons können via ThemeDesigner ausgeblendet werden.
        ---
        Das Projecta Layout wandelt quasi den normalen Kopfbereich in eine fliegende Links Spalte.
        Das Hauptseiten-Layout bleibt weiterhin das normale Content-Page Seitenlayout (nicht Sidebar left) und das Home Seitenlayout.
        http://www.premium-contao-themes.com

        Kommentar


        • #5
          Vielen Dank, hab ich verstanden. Ich habe es nun geschaft die Suche einzublenden, aber leider sieht diese anders aus als in der Demo. Klicke auf die Grafik für eine vergrößerte Ansicht

Name: Bildschirmfoto 2021-10-13 um 14.40.22.png
Ansichten: 47
Größe: 125,2 KB
ID: 23591

          Ist da was bei der Installation schief gegangen? Oder sind diese Anpassungen immer notwendig und die Demo entspricht nicht exakt dem, was dann ausgeliefert wird? Ich möchte ungern alles löschen, von vorne anfangen und dann merken das ich mir das hätte sparen können.

          Kommentar


          • #6
            Die Suche ist eigentlich nur ein Lupen-Symbol. Siehe: https://eclipse.premium-contao-theme...-projecta.html
            Ich kann mir nicht vorstellen, dass diese deutliche Abweichung nicht sofort aufgefallen wäre. Handelt es sich um eine frische Ausgangs-Installation oder um eine Update-Installation?
            http://www.premium-contao-themes.com

            Kommentar


            • #7
              Ja, eben - in der Demo ist nur ein Lupensymbol das ich so auch gerne hätte. Das war eine frische Ausgang-Installation.

              Kommentar


              • #8
                Ich habe soeben eine Neuinstallation Contao 4.9.12 und Eclipse X erstellt und die Demo Projekta installiert.
                Das Lupen-Icon wird standardmäßig sauber dargestellt. Siehe Screenshot.
                Gibt es einen Link zur Website?
                *********************
                Neu: Kostenloser Contao Installer 3.0
                *********************
                Contao und Erweiterungen in wenigen Sekunden laden, installieren und updaten - ohne Composer oder Contao Manager.

                Kommentar


                • #9
                  Ja, gibt es: http://telecrew.de/home-538.html

                  Bei mir fehlte auch von Anfang an der Sprachenumschalter. Dann werde ich die Tage alles löschen und neu installieren. Danke!

                  Kommentar


                  • #10
                    Soweit ich das so sehen kann ist der Sprachwechsler über den ThemeDesigner ausgeblendet worden:
                    ThemeDesigner aktivieren > Header > Items > HIDE: LANGSWITCH wieder deaktivieren.

                    Bei der Suche scheint das falsche Modul hier über die Seitenlayouts eingebunden zu sein. Da müsste in der Kopfzeile das FE-Modul Search Trigger sein.
                    *********************
                    Neu: Kostenloser Contao Installer 3.0
                    *********************
                    Contao und Erweiterungen in wenigen Sekunden laden, installieren und updaten - ohne Composer oder Contao Manager.

                    Kommentar


                    • #11
                      Das mit dem Sprachenwechsler hat geklappt, die Änderung hab ich mir vielleicht vergessen zu notieren. Ein Search Trigger Modul finde ich nicht. Aber vielleicht ist es wirklich besser nochmal von vorne anzufangen.

                      Kommentar


                      • #12
                        Dann wurde das Modul wahrscheinlich entfernt, da es per Default ein Teil des Theme ist. Siehe Screenshot.
                        *********************
                        Neu: Kostenloser Contao Installer 3.0
                        *********************
                        Contao und Erweiterungen in wenigen Sekunden laden, installieren und updaten - ohne Composer oder Contao Manager.

                        Kommentar


                        • #13
                          Danke, das hat geklappt. Ich brauche noch Inhalte (Text und zwei Bilder) unterhalb vonHauptmenü & Lupe. Tim schrieb das das am besten mit Artikeln zu realisieren sei. Da habe ich aber das Problem, das ich eine Überschrift habe, die ich nicht gebrauchen kann. Wie kann ich die deaktivieren?
                          Oder muss ich dann doch den Weg über Layout / Themes / Frontend Module / Eigener HTML Code gehen?

                          Kommentar


                          • #14
                            Hallo,
                            es handelt sich also um eine nachträglich veränderte Installation. Bitte für den Support jede Form von Individualisierungen vorab benennen!
                            ---
                            Um welche Überschrift handelt es sich? Diese kann eigentlich nur in einem der Standard-Module angelegt sein oder in einem nachträglich hinzugefügten Element. Per CSS ausblenden geht immer
                            http://www.premium-contao-themes.com

                            Kommentar


                            • #15
                              Kommt auf die Definition an - jede Webseite ist wohl eine nachträghlich veränderte Installation.

                              Ich verändere ja nicht die Installation, sondern will nur zusätzliche Inhalte einbinden. Aber das ist vermutlich Haarspalterei darüber zu diskutieren. Ich hab gestern die Seite neu installiert um von vorne anzufangen.

                              Bei der Überschrift handelte es sich um die Überschriften des oder der Artikeln die dort angezeigt wurden.

                              Das ist mein erstes Contao Projekt. Ich wollte das von Grund auf sauber anpacken, daher wollte ich jetzt nicht einfach einen Artikel an der Stelle veröffentlichen und dann den Artikelnamen einfach per CSS ausblenden, wenn es vielleicht einen "saubereren", bzw. eleganteren Weg gibt.

                              Für mich ist es irgendwie nicht logisch, die Artikel die in der Seitenleiste erscheinen sollen, in den Artikel-Seitenbaum einzutragen. Oder habe ich da was falsch gemacht? Ich hatte testweise unter Artikel zwei Artikel in der Home-Seite angelegt und die mir dann in der Seitenleiste der Startseite anzeigen lassen. Dort wurden mir die beiden Artikeln mit Überschrift und Text, bzw. Grafik angezeigt.

                              Ich habe nun in der neuen Installation unter Layout / Themes / Seitenlayouts / Home Seitenlayout / Eingebundene Module das Artikel-Modul für die Kopfzeile angelegt. Dann habe ich einen Artikel für Home anlegt und in der Kopfzeile anzeigen lassen.

                              Das Ergebnis nun aber war eine weiße leere Fläche zw. Menü und der Zeile mit Sprachenwahl und dem Lupenymbol, welches ein leerer Div-Container ist. Die weiße Fläche kommt wohl von den Padding-Klassen im Artikeln. Aber es kommt kein Artikel.

                              Bei Full width Klasse ist keine wiße Fläche vorhanden, bei allen anderen Darestellungsklassen schon.

                              Artikel Template war mod_article (Standard, Eclispe).

                              Gebe ich eine Teaser-CSS-ID und Klasse an, wird diese nicht übernommen.

                              Was mache ich falsch?

                              Kommentar

                              Lädt...
                              X