Ankündigung

Einklappen
Keine Ankündigung bisher.

Google Fonts lokal einbinden.

Einklappen
Dieses Thema ist geschlossen.
X
Das ist ein wichtiges Thema.
X
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Google Fonts lokal einbinden.

    Hi Leute,
    hier ist ein tolles Tool: https://google-webfonts-helper.herokuapp.com

    VG, Tim
    http://www.premium-contao-themes.com

  • #2
    Hier ein flinkes Beispiel einer kleinen Webseite mit "Cinematic". (dies kann auf andere Themes, wie auch Eclipse angewendet werden)

    1. Das autom. Laden der Schriften deaktivieren. Das Cinematic Theme läd ausschließlich über Contaos Seitenlayouts > Webfonts die Schriften. Die Voreinstellung leeren und speichern. Die Seite läd jetzt ohne Schriften bzw. Fallback-Schriften des Browsers. (Eclipse Theme) Das Laden autom. Laden von Schriften über den ThemeDesigner kann in den Systemeinstellungen deaktiviert werden (pct_themer Modul ab Version 2.10.x)

    2. Bei Google die gewünschten Schriften laden. Das Cinematic Theme baut auf den Schriften "Lato, Crimson Text" auf. https://fonts.google.com/
    Klicke auf die Grafik für eine vergrößerte Ansicht

Name: screenshot_3145.jpg
Ansichten: 1347
Größe: 78,4 KB
ID: 11425


    3. Die Schriften hochladen nach: cto_layout/fonts (ohne Unterordner, einfach die Schriftdateien direkt in den Ordner)
    Klicke auf die Grafik für eine vergrößerte Ansicht

Name: screenshot_3142.jpg
Ansichten: 1339
Größe: 61,0 KB
ID: 11426


    4. Google-Webfonts-Helper aufrufen und die nötigen Schriften inkl. der gewünschten Schnitte auswählen. Der Generator erstellt das CSS für uns. (Bei der Auswahl getreu dem Motto: Viel hilft viel. ).
    Klicke auf die Grafik für eine vergrößerte Ansicht

Name: screenshot_3147.jpg
Ansichten: 1323
Größe: 71,3 KB
ID: 11427



    5. customize.css aufrufen und die jeweiligen CSS-Blöcke oben einfügen. (siehe Anhang)


    6. Eventuelle Caches leeren: Seitencache, Browsercache usw.

    Angehängte Dateien
    Zuletzt geändert von Tim; 20.06.2018, 11:22.
    http://www.premium-contao-themes.com

    Kommentar


    • #3
      Hinweis zur Nutzung von Google Maps. Danke dir Daniel - das ist ein wichtiger Punkt.
      Google Maps läd Google Fonts (Roboto) in die Seite. Google Maps setzt oberhalb des gewohnten Contao-Head CSS und auch den Google Fonts Aufruf ein.
      Abhilfe wird hier nur das allgemeine Zustimmen zum Laden von externen Quellen wie Google schaffen.

      - Klicke auf die Grafik für eine vergrößerte Ansicht

Name: screenshot_3165.jpg
Ansichten: 1331
Größe: 120,2 KB
ID: 11459

      Zuletzt geändert von Tim; 07.06.2018, 09:36.
      http://www.premium-contao-themes.com

      Kommentar


      • #4
        Hallo Tim, leider habe ich das Problem, dass der Themedesigner nicht die Einstellung zum Deaktivieren der Google Fonts anzeigt. Update des Themedesigners habe ich gemacht, auch Cache usw. geleert. Woran kann dies liegen?

        Kommentar


        • #5
          Zitat von tanjusch Beitrag anzeigen
          Hallo Tim, leider habe ich das Problem, dass der Themedesigner nicht die Einstellung zum Deaktivieren der Google Fonts anzeigt. Update des Themedesigners habe ich gemacht, auch Cache usw. geleert. Woran kann dies liegen?
          Prüfe, dass du Modulversion >= 2.10.0 des pct_themer Moduls installiert hast (siehe changelog.txt im Modulordner). In 2.10 wurde diese Option erst ergänzt. Unter Contao 4 muss der Symphony Cache (var/cache Ordner) ggf. manuell geleert werden. Die Einstellung findet sich dann unter SystemEinstellung > Premium Contao Themes - ThemeDesigner - Einstellungen
          (Module immer 1zu1 ersetzen. Keine Duplikate im system/modules Ordner anlegen)
          Zuletzt geändert von Tim; 11.06.2018, 10:09.
          http://www.premium-contao-themes.com

          Kommentar


          • tanjusch
            tanjusch kommentierte
            Kommentar bearbeiten
            Also laut changelog.txt habe ich die Version 2.10.1, ich nutze Contao 3.5. - muss man den Themedesigner aktivieren. Das einzige was ich in den Einstellungen finden kann, ist "Themedesigner ausblenden + deaktivieren". Momentan habe ich ihn ausgeblendet.

        • #6
          Internen Cache löschen
          http://www.premium-contao-themes.com

          Kommentar


          • tanjusch
            tanjusch kommentierte
            Kommentar bearbeiten
            Es hat nun doch funktioniert … nach hundertmal Cache löschen usw. aber jetzt klappts, vielen Dank!
            Zuletzt geändert von tanjusch; 11.06.2018, 10:41.

        • #7
          Aloha, ich muss hier nochmal einhacken...
          ich habe eine alte 3.5.24 Installation mit PCT usw. hier sollen auch die über den TD eingebunden Google Fonts raus...
          (Fonts lokal drin css alles startklar.)
          In den Seitenlayouts sind alle eingebunden Font entfernt! cache gelöscht usw.
          unter Einstellungen gibt es in der Version scheinbar noch keine Möglichkeit die GF zu deaktivieren bzw. nicht zu laden.
          Frage: Wie bekomme ich die GFs da raus? Muss ich wie oben beschriebene erst das Modul updaten damit die Funktion da ist, geht das nicht einfacher?
          SG, Danke

          Kommentar


          • #8
            https://forum.premium-contao-themes....onts-entfernen
            http://www.premium-contao-themes.com

            Kommentar

            Lädt...
            X