Ankündigung

Einklappen
Keine Ankündigung bisher.

Update auf aktuelle Version

Einklappen
Dieses Thema ist geschlossen.
X
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Update auf aktuelle Version

    Hallo Zusammen,

    ich bin leider ein bisschen wie die Jungfrau zum Kind dazu gekommen eine Contao-Webseite zu betreuen. Mittlerweile hab ich mich auch einigermaßen eingearbeitet. Nun läuft die Webseite noch auf einer ziemlich alten Version 3.5.18. Im Moment wird der Server auch noch mit PHP 5.6 betrieben, was mir ein Dorn im Auge ist. Daher wollte ich ein Update auf Contao 3.5.40 machen und die PHP Version auf 7.X umstellen. Das Update hat auch soweit geklappt. Nur beim Umstellen der PHP Version bekomme ich Fehler der Form:

    PHP Fatal error: Uncaught exception 'Error' with message 'Function name must be a string' thrown in /.../system/modules/pct_customelements/PCT/CustomElements/Core/Hooks.php on line 413

    Die Webseite verwendet das Quantum Theme, welches aber schon lange nicht mehr aktualisiert wurde. Das würde ich jetzt gerne nachholen, da ich die Hoffnung habe, dass damit die Fehler behoben sind. Und hier kommen wir zum eigentlichen Problem: Woher bekomme ich ein aktuelleres Theme für Contao 3.5.40? Soweit ich das verstanden habe, ist das ja ein bezahltes Theme. Die Zugangsdaten für den Kundenbereich kenne ich aber leider nicht. Welche Möglichkeit habe ich, um hier weiter zu kommen? Das Quantum Theme kann man leider nicht mehr kaufen (oder ich hab es einfach nicht gefunden), sonst hätte ich es einfach noch mal gekauft, damit ich es dann aktualisieren kann.

    Ich freue mich über jede Hilfe.

    Vielen Dank
    Zuletzt geändert von AK-Loop; 18.05.2020, 20:50.

  • #2
    Hi,

    wenn Du auf Contao 3.5.40 aktualisierst und alle PCT Module aktuell sind (das scheint hier nicht der Fall zu sein), sollte der Betrieb mit Quantum kein Problem sein. Selbst ein Update auf Contao 4.4 ist möglich.
    Ich selbst betreue auch noch mehrere Websites mit Quantum auf Contao 4.4 und PHP 7.3 .

    Falls Du keinen Zugang zu den aktuellen PCT Modulen hast würde ich dazu mal direkt bei @PCT anfragen.

    Gruß
    tschero
    https://www.webdesign24.biz
    https://www.mein-panorama.de

    Kommentar


    • #3
      Hallo!
      Ich klinke mich mal ein.
      Meine Frage hierzu wäre, ob man mit dem Quantum Theme auch noch auf Contao 4.9 updaten kann?
      Oder ist die Contao-Version 4.4 das Maximum, was möglich ist?
      Danke und Grüße,
      Stefan

      Kommentar


      • #4
        Ich habe noch kein Update mit Quantum auf 4.9 gemacht.
        ich denke, dass es grundsätzlich möglich sein sollte.
        Ohne Nacharbeit wirds aber m.E. nicht gehen.

        Gruß
        tschero
        https://www.webdesign24.biz
        https://www.mein-panorama.de

        Kommentar


        • #5
          Bezogen auf das neue Update von Eclipse und dem notwendigen Umbenennen verschiedener Templates.
          Welche Templates müsse denn hier bei Quantum umbenannt und welche Module angepasst werden?
          Gruß
          https://www.webdesign24.biz
          https://www.mein-panorama.de

          Kommentar


          • #6
            Zitat von tschero Beitrag anzeigen
            Bezogen auf das neue Update von Eclipse und dem notwendigen Umbenennen verschiedener Templates.
            Welche Templates müsse denn hier bei Quantum umbenannt und welche Module angepasst werden?
            Gruß
            Keine Änderungen. CE erlaubt dort weiterhin die Auswahl aller Templates.
            http://www.premium-contao-themes.com

            Kommentar


            • #7
              HI Tim,

              ich klinke mich hier noch mal mit einer kleinen Verständnisfrage ein.
              Keine Änderungen. CE erlaubt dort weiterhin die Auswahl aller Templates.
              Heißt dass jetzt, bezogen auf das Update von Eclipse und den daraus resultierenden, notwendigen Anpassungen, dass bei Quantum AUCH diese Anpassungen gemacht werden müssen oder kann ich einfach auf Contao 4.4.50 aktualisieren und die Templates sind dann schon ausgewählt?

              Es stehen mehrere Updates von Quantum in der Pipeline

              Gruß
              tschero
              https://www.webdesign24.biz
              https://www.mein-panorama.de

              Kommentar


              • #8
                Zitat von tschero Beitrag anzeigen
                HI Tim,

                ich klinke mich hier noch mal mit einer kleinen Verständnisfrage ein.

                Heißt dass jetzt, bezogen auf das Update von Eclipse und den daraus resultierenden, notwendigen Anpassungen, dass bei Quantum AUCH diese Anpassungen gemacht werden müssen oder kann ich einfach auf Contao 4.4.50 aktualisieren und die Templates sind dann schon ausgewählt?

                Es stehen mehrere Updates von Quantum in der Pipeline

                Gruß
                tschero
                Die Templatenamen-bezogenen Updates sollten in Q nicht nötig sein. Die Anpassungen von CE gegenüber 4.9 waren ausschlaggebend.
                http://www.premium-contao-themes.com

                Kommentar


                • #9
                  Hallo Leute,

                  wir könnten ja an dieser Stelle mal alle Informationen zusammentragen, um ein Update von Quantum auf die aktuelle Contaoversion hinzubekommen. Es sind ja einige "Baustellen", die da zu bearbeiten sind.
                  @PCT: Bitte den Thread nicht schließen, auch wenn Quantum nicht für Contao 4 gedacht ist.

                  Ich fange gleich mal an:
                  Zuletzt geändert von tschero; 17.02.2021, 18:34.
                  https://www.webdesign24.biz
                  https://www.mein-panorama.de

                  Kommentar


                  • #10
                    1) Fehler: Seite wird nicht angezeigt.

                    2) Frontendanzeige: Es ist ein Fehler aufgetreten

                    3) Fehler im Log:
                    Code:
                    Argument 2 passed to Contao\Controller::getTemplateGroup() must be of the type array, string given, called in .../system/modules/pct_customelements/PCT/CustomElements/Backend/TableCustomElement.php on line 77
                    4) ToDo:
                    Im Template "TableCustomElement" im oben zu sehenden Pfad findet sich folgender Code mehrfach wieder:
                    Code:
                    $arrCustomElementTpl = $this->getTemplateGroup('customelement', $intPid);
                    Hier kann das ", $intPid" überall gelöscht werden. So läuft die Seite wieder.
                    Code:
                    $arrCustomElementTpl = $this->getTemplateGroup('customelement');
                    5) Contao Version: 4.9.11

                    6) Weitere Quellen im Forum: -

                    7) Bemerkungen:
                    Die Fehlermeldung besagt zwar, dass ein Array erwartet und statt dessen ein String übergeben wird, aber es funktioniert. Wer dafür eine Erklärung hat; ich würde mich über eine Info freuen
                    Zuletzt geändert von tschero; 17.02.2021, 18:49.
                    https://www.webdesign24.biz
                    https://www.mein-panorama.de

                    Kommentar


                    • #11
                      1) Fehler: Keine Templateauswahl bei Core-Inhaltselementen im Backend möglich. Inhaltselement wird nicht im Frontend angezeigt.

                      2) Frontendanzeige: Keine Fehleranzeige - aber das Inhaltselement wird nicht im Frontend angezeigt.

                      3) Fehler im Log: -

                      4) ToDo: Hier können die Coretemplates in das Verzeichnis "templates/quantum" kopiert werden.

                      5) Contao Version: 4.9.11

                      6) Weitere Quellen im Forum:
                      https://forum.premium-contao-themes....9107#post19107

                      https://community.contao.org/de/show...l=1#post525907

                      7) Bemerkungen:
                      Es funktioniert zwar, aber leider ist das m.M.n. keine gute Idee, da man bei jedem Coreupdate theoretisch auch die kopierten Templates überprüfen bzw. ersetzen müsste.
                      Hat hier ggf. jemand einen anderen Lösungsweg?
                      Zuletzt geändert von tschero; 17.02.2021, 19:00.
                      https://www.webdesign24.biz
                      https://www.mein-panorama.de

                      Kommentar


                      • #12
                        1) Fehler: Nach dem Editieren von den Seiteneigenschaften "Experteneinstellungen: CSS-Klasse", wird der Inhalt nicht übernommen. Bedeutet, dass eine Klasse im Backend gelöscht werden soll, dies jedoch nicht gespeichert wird und die Klasse weiterhin im Feld eingetragen ist.

                        2) Frontendanzeige: -

                        3) Fehler im Log: -

                        4) ToDo: Noch keine Lösung

                        5) Contao Version: 4.4.55 und 4.9.11

                        6) Weitere Quellen im Forum: -

                        7) Bemerkungen:
                        Hat da jemand eine Erklärung für und wo man da ggf. ansetzt? Kann das jemand nachvollziehen?
                        Zuletzt geändert von tschero; 17.02.2021, 19:38.
                        https://www.webdesign24.biz
                        https://www.mein-panorama.de

                        Kommentar


                        • #13
                          Die Zugangsdaten für den Kundenbereich kenne ich aber leider nicht.
                          Das Theme wurde bereits zum 1.1.2019 offiziell eingestellt und das Produkt aus dem Shop entfernt. Der Download stand noch weitere 6 Monate bereit.

                          Welche Möglichkeit habe ich, um hier weiter zu kommen?
                          Die letzte offizielle Version steht für Nachlizenzierungen weiterhin im VIP-Store bereit: https://www.premium-contao-themes.com/vip-store.html

                          Ich empfehle das Update über einen unserer Partner durchführen zu lassen, oder (was hier naheliegt ) direkt über tschero.

                          Ich schließe den Thread, Update Threads zu Quantum gibt es genug.
                          http://www.premium-contao-themes.com

                          Kommentar

                          Lädt...
                          X