Ankündigung

Einklappen
Keine Ankündigung bisher.

Google Analytics 4

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • #16
    Zitat von bootsybubba Beitrag anzeigen
    <?php

    /**
    * To use this script, please fill in your Google Analytics ID below
    */
    $GoogleAnalyticsId = 'UA-XXXXX-X';


    /**
    * DO NOT EDIT ANYTHING BELOW THIS LINE UNLESS YOU KNOW WHAT YOU ARE DOING!
    */
    if ($GoogleAnalyticsId != 'UA-XXXXX-X' && !BE_USER_LOGGED_IN && !$this->hasAuthenticatedBackendUser()): ?>

    <script>

    function initGoogleAnalytics()
    {
    (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagNa me(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)} )(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
    ga('create', '<?= $GoogleAnalyticsId ?>', 'auto');
    ga('set', 'anonymizeIp', true);
    ga('send', 'pageview');
    }

    // Optin privacy setting token
    var token = localStorage.getItem('user_privacy_settings');
    if( token == undefined )
    {
    token = '';
    }
    if(token.indexOf(3) >= 0)
    {
    initGoogleAnalytics();
    }

    // listen to privacy event
    jQuery(document).on('Privacy.changed',function(eve nt,params)
    {
    if(params.level.indexOf(3) >= 0)
    {
    initGoogleAnalytics();
    }
    });

    </script>

    <?php endif; ?>
    Dieses Templates hier ist veraltet. Ich habe es soeben mit dem Template aus dem Download-Paket Eclipse X4 verglichen.
    Bitte das aktuelle aus dem Login-Bereich verwenden.

    upload/system/modules/pct_theme_templates/templates/analytics/analytics_google.html5
    *********************
    Neu: Kostenloser Contao Installer 3.0
    *********************
    Contao und Erweiterungen in wenigen Sekunden laden, installieren und updaten - ohne Composer oder Contao Manager.

    Kommentar


    • #17
      Hmmh, ist ja krass, ich hab gestern 2 x einen Download gemacht und eben noch mal, im changelog steht 4.0.10 nicht 4.0.11.

      Kommentar


      • #18
        Hm, klingt nach Browsercache. Ich hatte das Problem öfter in Chrome. Ich würds mal mit einem anderen Browser versuchen oder den Cache leeren.
        *********************
        Neu: Kostenloser Contao Installer 3.0
        *********************
        Contao und Erweiterungen in wenigen Sekunden laden, installieren und updaten - ohne Composer oder Contao Manager.

        Kommentar


        • #19
          Ich hab den Firefox genommen und eben auch noch mal alle Caches und Websitedaten gelöscht, es bleibt bei 4.0.10 und eben auch noch mal mit Opera probiert.

          Kommentar


          • #20
            1000 mal Entschuldigung. War mein Fehler. Ich hatte hier die ganze Zeit auf der DEV Umgebung upgedatet und getestet.
            Ist jetzt aktuell. Bitte nochmals laden.
            *********************
            Neu: Kostenloser Contao Installer 3.0
            *********************
            Contao und Erweiterungen in wenigen Sekunden laden, installieren und updaten - ohne Composer oder Contao Manager.

            Kommentar


            • #21
              Korrigiertes Update geladen … und GA4 läuft.

              Kommentar


              • #22
                Entschuldigt meine mehr oder weniger dumme Frage, wie und wo muss man die neue ID eintragen?
                Das template aus dem analytics template erstellen und anschließend nur die obere von den zwei UA-xx... IDs tauschen und speichern.
                Was muss ich anschließend tun?

                Ps.: Muss ich noch was zusätzlich bei dem Privacy Manager Ändern?

                Kommentar


                • #23
                  Zitat von Dennis Beitrag anzeigen
                  Entschuldigt meine mehr oder weniger dumme Frage, wie und wo muss man die neue ID eintragen?
                  Das template aus dem analytics template erstellen und anschließend nur die obere von den zwei UA-xx... IDs tauschen und speichern.
                  Was muss ich anschließend tun?

                  Ps.: Muss ich noch was zusätzlich bei dem Privacy Manager Ändern?
                  Ab der Eclipse X Version 4 wird der API-Key in den Seiteneinstellungen der Root-Seite (Startpunkt einer Webseite) im Feld Theme-Einstellungen > Google Maps Schlüssel hinterlegt.
                  Nicht mehr im Template. Im Privacy Manager muss soweit nichts geändert werden. GGf. die Labels und die Beschreibungstexte, Cookie-Hinweistexte.
                  *********************
                  Neu: Kostenloser Contao Installer 3.0
                  *********************
                  Contao und Erweiterungen in wenigen Sekunden laden, installieren und updaten - ohne Composer oder Contao Manager.

                  Kommentar


                  • Roland
                    Roland kommentierte
                    Kommentar bearbeiten
                    Hallo Tom
                    Zitat: Ab der Eclipse X Version 4 wird der API-Key in den Seiteneinstellungen der Root-Seite (Startpunkt einer Webseite) im Feld Theme-Einstellungen > Google Maps Schlüssel hinterlegt.

                    Dieser Punkt bleibt mir verborgen, kannst du einen ScreenShot anhängen
                    Besten Dank und Gruss
                    Roland

                • #24
                  Anbei ein Screenshot aus dem Seitentyp "Startpunkt einer Webseite" (EclipseX >= 4.1)
                  Angehängte Dateien
                  Zuletzt geändert von Tim; 05.09.2022, 10:10.
                  http://www.premium-contao-themes.com

                  Kommentar


                  • #25
                    Hi Tim
                    Danke für die rasche Nachricht. Mhm...bei mir sieht das aus wie im beil ScreenShot.

                    Contao 4.13.2 - PC-Theme Ecplise X vom 30.04.2022 - www.wizart-company.ch

                    Muss noch was installiert oder angepasst werden ?

                    Nochmals Danke für deine Hilfe, Gruss Roland

                    Klicke auf die Grafik für eine vergrößerte Ansicht

Name: CPT-Theme-Einstellungen-0905.jpg
Ansichten: 84
Größe: 93,4 KB
ID: 25728

                    Kommentar


                    • #26
                      Welche Eclipse X Version ist installiert? Das Feld kam erst mit der Version 4.1 dazu. Schau mal in die templates/changelog.txt
                      Ansonsten das Theme updaten.

                      Schöne Grüße
                      Tom
                      *********************
                      Neu: Kostenloser Contao Installer 3.0
                      *********************
                      Contao und Erweiterungen in wenigen Sekunden laden, installieren und updaten - ohne Composer oder Contao Manager.

                      Kommentar


                      • Roland
                        Roland kommentierte
                        Kommentar bearbeiten
                        Daran lags, eben ein Update gemacht - nun ist alles ok. 
                        Vielen Dank für die rasche *****Hilfe !

                        Sonnige Grüsse
                        Roland
                    Lädt...
                    X