Ankündigung

Einklappen
Keine Ankündigung bisher.

Eigene Fonts in den Themdesigner

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Eigene Fonts in den Themdesigner

    Hellö,
    weil ich ja dieses Teil so praktisch finde Gibt es eine Möglichkeit eigene Fonts (Firmenschriften) in den Themdesigner zu bekommen?
    Vielen Dank im voraus

  • #2
    Es werden nur Google Fonts unterstützt. Eigene Schriften müssen immer über @font-face eingebunden werden.
    http://www.premium-contao-themes.com

    Kommentar


    • #3
      Hallo Tim,
      vielen Dank für die rasche Rückmeldung! So werd ich eh lösen…
      Zitat von Tim Beitrag anzeigen
      Es werden nur Google Fonts unterstützt. Eigene Schriften müssen immer über @font-face eingebunden werden.

      Kommentar


      • #4
        Hi,

        die Google Font hier fehlt: https://fonts.google.com/specimen/Cantarell

        wir haben versucht diese über die Webfonts Input Box im Seitenlayout einzubinden - ohne Wirkung.

        Wie können wir vorgehen?

        Es wäre gut, diese im Theme Designer auswählen zu können.

        Grüße,

        Alexander




        Kommentar


        • #5
          Weitere Google Fonts können wie folgt ergänzt werden: Siehe Doku: https://help.premium-contao-themes.c...igner-pro.html
          http://www.premium-contao-themes.com

          Kommentar


          • #6
            Wenn ich den Code in einen Editor (Brackets, UTF-8) kopiere und meinen Wunschfont eintrage, klappt das erstmal gut. Der TD gibt die Schrift in der Auswahl aus und zeigt sie auch im Preview an. Klicke ich im TD speichern, hängt sich Front- und Backend auf. Das Problem entsteht in der localconfig. Beim Speichern zerschießt es die Syntax. Leerzeichen und '=' entstehen an falscher Stelle. Also die localconfig korrigieren und wieder einloggen. Contao ist dann wieder ok aber der TD ist ja noch aktiv. Beim Deaktivieren zerschießt es dann wieder die Syntax. Das Spiel beginnt verbindlich neu.

            Kannst du den Code hier in einer Formatierung ausgeben, die sich sicher kopieren lässt? Offensichtlich muss ich da immer noch einen Bug haben.

            Kommentar


            • #7
              Der Code muss unter die dicke grüne Hinweis-Linie in der localconfig.php eingesetzt werden, sonst wird Contao die Zeilen wieder editieren.

              Eine initconfig.php Datei tut es auch.
              http://www.premium-contao-themes.com

              Kommentar


              • #8
                "dicke grüne Hinweislinie"?

                Klicke auf die Grafik für eine vergrößerte Ansicht

Name: Bildschirmfoto 2021-06-18 um 10.48.17.png
Ansichten: 47
Größe: 116,6 KB
ID: 22790

                Kommentar


                • #9
                  haha ja. Contao speichert seine Systemeinstellungen quasi ganz oben innerhalb zweier Kommentare. (bei mir sind die grün )

                  Also nach ### INSTALL SCRIPT STOP ### müssen eigenen Sachen rein. Gute Alternative ist eine /system/config/initconfig.php -> die muss man ab Contao 4 aber selbstständig anlegen.

                  Klicke auf die Grafik für eine vergrößerte Ansicht  Name: screenshot_7103.jpg Ansichten: 0 Größe: 28,8 KB ID: 22792
                  http://www.premium-contao-themes.com

                  Kommentar


                  • #10
                    ahhh. Ich hielt das für reine Kommentarzeilen. Wieder was gelernt.
                    Danke. Läuft.

                    Kommentar


                    • #11
                      Läuft doch noch nicht so ganz. Safari zickt mal wieder (iPhone als auch Desktop). Die Typo wird dort ersetzt. Ich kann mich dunkel erinnern, dass das mit einer zusätzlichen Formatierung in der CSS zu beheben war. Hast du eine Idee?

                      HTML-Code:
                      $GLOBALS['PCT_THEMEDESIGNER']['fonts']['Mansala'] = array
                      (
                      'label' => 'Mansala',
                      'family' => 'Mansala',
                      'styles' => 'regular:400',
                      'default' => 'regular:400',
                      );

                      Kommentar


                      • #12
                        Vielleicht wurde die Schrift nie ausgewählt und damit ordnungsgemäß gespeichert. Würde sich mit diesem Thread decken: https://forum.premium-contao-themes....times-als-font
                        http://www.premium-contao-themes.com

                        Kommentar


                        • #13
                          Habe sie jetzt manuell eingebunden. Funktioniert.
                          Warum aber Chrome und FF damit kein Problem hatten erschließt sich mir nicht.

                          Kommentar

                          Lädt...
                          X