Ankündigung

Einklappen
Keine Ankündigung bisher.

Kein Zugriff auf PDF im geschützten Ordner über Contao Backend

Einklappen
Dieses Thema ist geschlossen.
X
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Kein Zugriff auf PDF im geschützten Ordner über Contao Backend

    Ich hatte bereits im Contao Forum recherchiert und es ist offenbar kein Feature:

    Seit irgendeiner Minor Version von Contao < 4.4.50 ist wohl der HTTP-Zugriff auf Dateien über einen angemeldeten Backend User (auch Admin) nicht mehr möglich, wenn sich die Datei in einem geschützten Ordner befindet.
    Ich kann die Dateien zwar sehen und bearbeiten, aber nicht herunterladen (PDF).

    Betroffen sind Installationen mit Eclipse9 oder EclipseX neueren Datums. Kann das jemand nachstellen?

    Möglicherweise sind es auch nur CC Installation, die betroffen sind, das muss ich noch verifizieren.

    Läuft alles mit PHP 7.3, Contao 4.4 oder 4.9


  • #2
    Meinst du Zugriff aus dem FE heraus? Das ist nur für öffentliche Ordner erlaubt, unabhängig des Backend Users, soweit ich weiss (Symlink muss existieren, sonst ist der Ordner 404)
    http://www.premium-contao-themes.com

    Kommentar


    • #3
      Ich meine aus dem Backend heraus. Meine Redakteure haben bislang über das Backend ganz einfach PDFs herunterladen können, die über das Notification Center dort abgelegt wurden (Upload über Formulare). Plötzlich " " funktioniert das nicht mehr. kein Cursor Pointer beim Icon, kein a-Tag mit dem Link und auch über Info ist der Download nicht möglich.

      In "cleanen" Installationen ohne PCT Theme funktioniert es noch.


      Kommentar


      • #4
        Über das i-Icon den Download-Button, richtig? Funzt bei mir sowohl mit als auch ohne Theme, in öffentlichen wie nicht öffentlichen Ordnern
        http://www.premium-contao-themes.com

        Kommentar


        • #5
          im Ernst? welche Version hast du verwendet und welchen Erweiterungsstand? Mit CC? Welche PHP Version? ich habe 7.3, könnte es daran liegen?

          Kommentar


          • #6
            Contao 4.4.54, 4.9.9
            EclipseX
            EclipseX + CC

            PHP auf allen 7.4
            Zuletzt geändert von Tim; 11.02.2021, 09:23.
            http://www.premium-contao-themes.com

            Kommentar


            • #7
              Scheint gelöst, hier war easy-themes wohl ursächlich in einer veralteten Version.

              Kommentar

              Lädt...
              X